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Training content

e Creating a new file based on ST-Ericsson FM template
o Setting variables and conditional text

o Paragraph tags and character tags

e Inserting a figure

e Inserting a table and table formats

e Cross references

o Using the global update functionality

o Tabulations

e Generating and importing the table of content

e Using the Copy special functionality
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Getting started with the IP specification template

o« Download the latest IP specification template from DMS@ST
(see slide #22. References)

o Save the template on your C drive
C://Program files/Adobe/FrameMaker/Templates

e Go to File/New/New document, select the IP specification template
o Update the title by renaming the Heading 1 <IP> specification name
o Example: <IP> specification name renamed as Keypad

o Save the file as t1xp_<IP name>_fs.fm

o Examples:
o tlxp_keypad_fs.fm if the file is stored in MPU_RTLIP or in DSA Dev VOB

o DBXXXX_V1_keypad.fm or APXXXX_V1_keypad.fm if the file is stored in
MMTC_DOC VOB
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Setting the document variables

o The following variables are used for a project
 Header: used for the device name, by default <DeviceName>

o DocRev#: used for the design specification revision number, by default
<Rev TBD>

o Doc#: used for design specification ID in Codex, by default <Internal
DRAFT>

o Recommendations
e DO NOT CHANGE THE SETTINGS IN THE DOCUMENT MASTER PAGES

e Only create variables that refer to your IP specification and do not
modify

e Only update the definition of the above-listed variables if you plan to
edit a stand-alone IP specification
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Changing/creating variables

e To change a variable or create a variable, go to Special/ Variable and
either select in the list or select Create a variable

e Double-click on the Description1 variable to open the variable
window

o Select ‘Edit Definition’ and type the new definition

o Select ‘Replace’

x zl
Variables: Name: |FefTitel

RPHZ - L

‘Descriptian —I Drefinition:

‘Dezcriphion

B DCE " I1=zer v aniables: Character Farmatz:
szgd;v RPN2 a| [<Default $Font>  a)

Dreszcription <Bold:>

y : ‘Descrphion2 < Caps»

HEfTIHEE Toct «Code: ||
RefTitle1 DocRevl < Codeltalics

CreateVariable.. | EditDefinifion.. || ghesder cLrossief>

<Helw 7>
RefTitle2 <Helvd: hd

Add | Change | Delete I

coce_|

Corvert bo Text... | Update I

Cancel _|
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Using conditional text

e Only use the conditional tags already defined:

o Level3 is used for internal information not to be shown in the design
specification

o Level2 for the information to be included in the internal version of the
design specification but not in the customer design specification

o DBxxxx_V1 or DBxxxx_V2 if relevant for your project

e To hide internal information tagged as Level3:
* go to Special>Conditional Text |

Current Selection |=:

" Unconditionat

o select the Show/Hide button {ncondttionat

{* Conditional
+ select Show e
» Recommendation: when editing Elnétmkt
the document apply the Show All EIQ'_}TI

setup
Apply I Edit Condition T ag... | Showe/Hide...
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Paragraph and character tags

» Select the icons on the right of the document frame to open _the list
of paragraph tags and character tags e

AppxHeading]
AppxHeading2
AppxHeading3

o Only use the pre-defined tags B

Bodylndent2
Caution
Codel

e Do not change any setting o

Codbuten
CovBulletz
CovHeadl

CovHead2
Danger

FigCap
f Catalog EI FigFootnotel

FigFootnote +
Default A Fort Headingl

Furial? Heading2
Ariald Heading3
Headirgd
Bold Headlnit1 —
Laps HeadUrit2
Code HeadUnif3
Codeltalic HeadlIrd4

Lizt1
CrozsRef List +

Italic: ListZa

. Ligt2a+
O-verline ListBullet]
Guestion ListBullet?

Subszcript ListE quation

i Hate

gupirslcrlpt Notes

Ymba Matel
Motel+
Regddress
Regspplicability
RegBody
RegBuffer
FegBullet]
FegBullet2
RegCaution
Reglesc

Reghame LI

Delete. ..

[» 1%

"B Untitled1.fm Y ||

o1 2 3 &5 E 7 8 8 10 M 12 13 14 15 1B 17 18e 13 20

2 = Device Name = =IP= specification name

..................................................................................................

N N i

Recommendations on the use of varialMes and conditional text: ]

éDo not change the zetting= in the document master pagesf

tial

=

Mrle nea tha randitianal faac alraadw dafinad T

L
LE
T
m
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Most used paragraph tags

o Type the text, place the cursor anywhere in the paragraph and select
the paragraph tag from the list (no need to select the whole
paragraph)

» Heading paragraph tags
 Headingl, Heading2, Heading3, Heading4
e HeadUn#1, HeadUn#2, HeadUn#3, HeadUn#4
e CoverHeadl, CoverHead?2
o Body paragraph tags
e Body
e Bodylndentl, Bodylndent?2,
e ListBullet1l and ListBullet2, List2a, List2a+
e Notel, Notel+, Note, Note+

e Codel, Codel+, Code2, Code2+
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Character tags

o Select the whole word or sections and apply the character tag from
the list

e Question character tag is useful to highlight a question or some sections
which need updating/defining later on

e Symbol is used for units (ohm, delta...)

o To retrieve the initial settings, use the ‘default paragraph font’
character tag
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Inserting a figure

o Type a return and select the ‘FigCap’ paragraph tag
e Go to Special/Anchored Frame and select the options
o Below current line, left-aligned and 14.25 cm width

e In the drawing window, select the frame line and apply a 0.5 point
black line ol

Inserting a figure

Anchored Frame x|

Ancharing Positian: (1]

elow Current Line

;Figure 1.} Inserting a figuref

Alignment; I Lett j

[T Cropped [ Floating

Sizer
Wfidth; |1 425 cm Height: |4.EI M
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Figure formats

o Few possibilities

e Use FrameMaker drawing menu to create

figures in the document

ook in Iﬂiscreenshuts j L £ -

'L_lj CC_ronfigSpec.jpg ll_"] RTLIP_checkout.jpg

] CC_MMTC Do jog [E|RTLIP_checkout_2.jpg

£ CC_SDMMC_rabat.jpg ¥ 5TnEs00_bodkL.jpg

,E‘J CC_version_history_example.jpg |!_‘] STnE500_bookz.jpg

|ﬂ CC_WOBS jpg ,ﬂ STnE500_custom_dsg_spec.jpg
_ |I_‘] FM1_figure.jpg ﬂ_‘:] STnB500_datashest.jpg
locurnents ,l_‘_’] FM_jcons, g |ﬂ STnE500_dsq_spec.jpg

,l_‘] FM_new_file.jpg |
,_lj] level0_settings . jpg

ﬂ levelZ_settings.jpg

ﬁ level3_settings. jpg

.5] MMTC_DOC_checkout_modemss_wrapper,jpg
|ﬂ modemss_wrapper_await_input.jpg

o Copy figures directly from MSVisio into the
anchored frame in FrameMaker

o Copy figures in SVG or EPS or PDF format

e Copy screenshots in PNG format

=
u Metwark: |_]modemss_wrapper_checkout‘]pg Dimensions: 810 x 555
,ﬂ modemss_wrapper_PMS_details.jpg Type: JPES Image
Size: 101 KB
| | i

e To import a figure in SVG, PNG or PDF format B —— e

Files of type: [ Files ) | Cancel |

‘ &+ |mport By Reference " Copy Into Document |

o Select the anchored frame,

e Go to File/Import/File
o Select ‘copy into document’

» Note: when importing a figure by reference,
make sure to store the figure in ClearCase
where the other users can find it
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Inserting a table

e Type a return and apply the ‘Anchor’ paragraph tag

e Go to Tables/Insert a table

» Select the table format T— Iz_i'

Body Rows: |1

o Table title: most commonly used

Heading Bows: |1
e Figure double: to insert two adjacent figures Eeoting Fows: [
. . I Cancel
o Invisible: to have regular and constant tabulated text [Bre]
Invisible table
Figire 25§ Figure 33§ 5 5
£ 5 §
5 5
5 5
TableTitle
& BB ]
§ § § §
§ § § §
§ § 5 §
§ § § §
§ § g §
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Inserting cross references or table footnotes

e To insert a cross reference
e Go to Special/Cross reference
o Select the paragraph tag among the list (FigCap, TableCap, Headingl,...)

o Select the cross reference format among Figure#, Table#, Chapter#,
Section#, Section#NamePage...

e To insert a table footnote
o Select the text related to the footnote
e Go to Special/Footnote

o To refer to an existing table footnote, go to Special/Cross reference and
select the TableFootnote paragraph tag, select the FootnoteAdditional
cross reference format
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Importing formats

e Open the files from which you want to import the
format

e In your file, go to File/Import/Format

« Select the file from which you want to

i m p O rt fo rm att I n g Irnpart from D ocument: |y e
Impart and Update:
o Se I ECt th e fO rm attl N g tO | m pO rt [ Paragraph Format: [ Beference Pages
[ Character Formats W Yanable Definitions
° Se I e Ct I m po rt [ Page Layouts [ Eru:uss.-ll:leference Eu:un.'nats
[ Table Formmats [v Conditional Text Settings

[ Color Definitions [ Math Definitions
[ Document Properties

Select All

YWhile L pdating, Bemowve:
| Manual Page Breaks | Other Farmat/Layout Ovemides

Cancel
(Mo Unda]
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Global updates for tables and tags

Open the Paragraph Designer menu or the Table Designer menu

Select and copy the ‘old tag’ in Paragraph design window

Open the paragraph tag window

Select the ‘new tag’

Global Update Options E|
. I1ze Properties in the Paragraph Designer:
e In Paragraph Design Al Fronetics
" Pagination Properties Only
e go to Global updates,
select Commands/Global update options Update Paragiaph Formats:
" Al Paragraphs and Catalog Entries
o Select ‘All properties’ ¢ Al Matching Tags in Selection
‘ ’ + Al Tagged |CelHeadind |
o Select ‘all tags
o Paste the ‘old paragraph tag’ in the window

e Confirm that you want all the ‘old tag’ to be replaced with the ‘new tag’
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Tabulations

o Tabulations in tables
o The TableBodyL paragraph tag already has pre-set tabulations

e Press at the same time the echap +tab keys to insert the tabulation

...........................................................................................................................................................

[2:9) i;,'LI}'LI}'j U uhiuhiahug
""""""""""" E jwwrw  uhohahes
"""""""""" 54 puwrw  uhuhehus
""""""""""" 34 pwwrw  uhuhahes
""""""""""" o uywrw  uhuhahes

..........................................................................................................................................................

o Tabulations in the “body” of the document (as opposed to tables or
figures)

o Go to Table > Insert Table
o Select the Invisible table format and set the number of rows and columns

o Type the text at your convenience in the table
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Tabulations (continued)

e The invisible table in FrameMaker looks as shown below

;‘gﬁfffffffiiéifi&iiié{ffffffffffffffffffffffﬁi[fi&iiié[éfffffffffffffffffffffffiiiiéiﬁf@}ffffffffffffffffffffffff?
S s WS jiiis
S s oo ws. S
§ i jilis jiiis

e Go to View and unselect Border and Text symbol to view the table as
in the final PDF

hukuh vhuhu uhuh
ijii] ijiji Jijiji
ijjij ijiji ijji
ijiji jiji jiji
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Generating the table of content

o Finalize the cut and paste of existing sections in the IP specification
and add the information in the new sections

o Save the file

o To generate the table of content

» Go to Special>Table of content

o Select Set

o Save the file newly generated (the file name corresponds to the file name
of the IP specification with TOC at the end
<FileName>TOC.fm

¥ Create Hypertest Links

Cancel

x
Suffie: [TOC Add File: | Before =]
Include Elements/Paragraphs: Don't Inchude:

M AppxHeading? - N Anchor il
M App=Heading e | Ml Eody

M &ppxHeading3 M B odylndent1

M Heading? ! Bodplndent2

f Heading2 _>| A Caution

1 Heading3 | 1 Code hd
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Importing the TOC in the IP specification

In the IP specification, go to
File>Import>File

Select the <FileName>TOC.fm
file and select Import by
reference

Add the <FileName>TOC.fm file
to source control in ClearCase,
so it is always available when
next updating the specification

Alternatively, select Copy into
document

o Make sure to generate the
TOC every time you update
the content

e Apply Edit>Update
references and select text
inset

e Apply the command
File>Import>File prior to
releasing the IP
specification

Look i II."_"} IP_zpecification_template j = I-:_c-i( v

1 IP_Specification_Template w1.0_struck,zip
@ IP_specification_template. auto.fm
Dezktop E IP_specification_template. Frm

@ IP_specification_template. Fm.lck,

E IP_specification_templateToC Fm

@ IP_specification_templateTOC, Fro.lck,
by Documents

My Recent
Documents

fy Diepot File narme: |F' specification_termplateT OC. fri
Filez af type: I.-’-'-.II File=s [*.7]
' |mport By Feference " Copy Inta Document

Lef L]

[mpart

[ oot |
Cancel |
o




The “Copy special” function

e The copy special function can be used to copy/paste the following
items

o Paragraph format
o Character format

o Table column format
o Select the text or table column
e Apply a right-mouse click

o Select Copy special and select the item of interest (either paragraph
format or table column width or character format)

o Select the text of table column width to modify and apply the Paste
command
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